Back to overview
EU1 - Degraded
Jan 12 at 04:04pm GMT+8
Affected services
EU1
Resolved
Jan 12 at 04:04pm GMT+8
EU1 region is experiencing slowness, we are investigating the issue.
Affected services
Resolved
Jan 12 at 04:04pm GMT+8
EU1 region is experiencing slowness, we are investigating the issue.
Affected services