Back to overview
Downtime

ASIA1 under maintenance.

Mar 10, 2026 at 5:34am UTC
Affected services
ASIA1

Resolved
Mar 10, 2026 at 5:49am UTC

ASIA1 region maintenance is done.

Created
Mar 10, 2026 at 5:34am UTC

ASIA1 region is now under maintenance.